问题 B: C++数组实验—一维数组元素查找

题目描述

定义包含 10 个整型数的一维数组,从键盘输入 10 个整数,然后再输入一个待查找的整数 x,判断如果能在数组中找到 x,则输出 x“ is found at ”、下标,否则输出 x“ is not found”。

说明:如果数组中找到多个与 x 相同的数,则只输出找到的首个元素。

输入

输入:第 1 行输入 10 个整数

第 2 行输入 1 个待查找的整数

输出

输出:x “ is found at”、下标(数据之间空 1 格)

或者:输出 x“ is not found”

样例输入

1
2
23 14 45 26 90 85 67 48 62 65
85

样例输出

1
85 is found at 5

提示

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include<iostream>
using namespace std;
int main() {
int arr[10],x,isFound=0;
for(int i=0; i<10; i++)
cin>>arr[i];
cin>>x;

for(int i=0; i<10; i++) {
if(x==arr[i]) {
cout<<x<<" is found at "<<i<<endl;
isFound=1;
}
}
if(isFound==0)
cout<<x<<" is not found"<<endl;
}