问题 D: C++类与对象——立方体类

题目描述

编写基于对象的程序,求长方柱(Bulk)的体积。数据成员包括长(length)、宽(width)、高(heigth)、体积,要求用成员函数实现下面的功能:

(1)由键盘输入长方柱的长、宽、高;

(2)计算长方柱的体积(volume)和表面积(areas);

(3)输出这长方柱的体积和表面积。

输入

长方柱的长、宽、高

输出

长方柱的体积和表面积

样例输入

1
2 3 4

样例输出

1
2
24
52

提示

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
#include<iostream>
using namespace std;
class Bulk{
double length,width,heigth;
public:
void input(){
cin>>length>>width>>heigth;
}
double volume(){
return length*width*heigth;
}
double areas(){
return 2*(length*width)+2*(width*heigth)+2*(length*heigth);
}
};
int main(){
Bulk a;
a.input();
cout<<a.volume()<<endl;
cout<<a.areas()<<endl;
return 0;
}